IBM Support

v9 Windows S-TAP Service Terminated Unexpectedly After Install

Troubleshooting


Problem

You have just installed a v9 Windows S-TAP release and the service is stopped.  The Windows Event log shows:
The GUARDIUM_STAP service terminated unexpectedly. It has done this 330 time(s). The following corrective action will be taken in 100 milliseconds: Restart the service.

Symptom

Around the same time, these events show:

Description:
The Nptrc service depends on the NpProxy service which failed to start because of the following error:
The system cannot find the device specified.

Description:
The driver was unable to attach to the Named Pipes device stack.

An S-TAP diagnostic will show a Veritas PBX (Private Branch Exchange) process, e.g.:
pbx_exchange.exe             1234 VRTSpbx  

 

Cause

Older versions of v9 Windows S-TAP have a conflict with nptrc.sys and npproxy.sys.

Resolving The Problem

After installation, restart PBX and then restart Windows S-TAP Service.
Or upgrade to the highest release of v9 S-TAP. 

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Product Synonym

IBM Security Guardium

Document Information

Modified date:
01 October 2018

UID

ibm10732055