IBM Support

Work Order creation updates the customer timezone to Delivery Service line Shipnode Timezone.

Troubleshooting


Problem

Attempts to create work order updates the timezone to Delivery Service (DS) line's Shipnode Timezone at Delivery Service line level as well as at work order level in IBM Sterling Order Management.


 

Symptom

Steps to simulate:

  1. Set a different Timezone (other than DS Line's Shipnode time zone) during order creation at DS line level.
     
  2. Create the work order.

As a result, the product is updating the timezone back to DS line's Shipnode Timezone at DS line level as well as at work order level.


 

Cause

This is working as designed.
 

Diagnosing The Problem

On work order creation, you see that the timezone field/column in YFS_ORDER_LINE  and YFS_WORK_ORDER table gets updated to the DS line Shipnode Timezone. This is not a problem but designed to sync the order DS line with the same time zone of the work order.

Resolving The Problem

For a delivery service when the work order is created, the time zone on the service line as well as the product line are updated based on the locale of the node that is performing the service.

This behavior is correct since the service will be provided in the node's time zone.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Component":"order management","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
27 August 2018

UID

ibm10729273