IBM Support

Unable to Start Multiple TM1 Servers at Once

Troubleshooting


Problem

From Cognos Configuration, user can start only one server at any given point in time. If a second server is started, it errors out with the following message: 

errorlevel1 exit 1
The IBM Cognos TM1 Server - <ServerName> Service could not be started
A system error has occurred. 
System error 1067 has occurred. 
The process terminated unexpectedly.  
 

Cause

This may be caused due to a port conflict.
Unless specified otherwise in the tm1s.cfg file, any server will communicate with port 5001 for HTTP requests. This means that when two servers, both of them with unspecified HTTP port numbers are started up, there is a port conflict on port 5001, and the second server errors out. 
 

Diagnosing The Problem

  • Open the tm1s.cfg file of both the servers. Both of them should be lacking a HTTPPortNumber parameter. 
  • Open the tm1server.log file of the server which does not start. You should see an error message of the following kind: 
    Server unable to listen on port 5001. Please check the log file for further details.
     

Resolving The Problem

Specify the HTTPPortNumber parameter in the tm1s.cfg file. Port Numbers should be between 5000 and 49151. 
The syntax is as follows: 
HTTPPortNumber = <Preferred Port Number> 

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Document Information

Modified date:
11 January 2019

UID

ibm10729199