IBM Support

Troubleshooting Single-Sigon (SSO) Issues in Cognos Analytics in IIS (Internet Information Services)

Troubleshooting


Problem

An accumulative list of technotes that cover common SSO issues in Cognos Analytics (R4 as of time of writing).

Symptom

SSO not working in Cognos Analytics

Cause

Web Server Configuration
Cognos Configuration

Resolving The Problem

Before trying to access Cognos via SSO please ensure access to Cognos first.
You should be able to access Cognos via the dispatcher URI: http://serverName:portNumber/bi/v1/disp
*Note you will be prompted to login.

1. Ensure the correct configuration document is being used:
Cognos 11.0.0 - 11.0.3 - http://www-01.ibm.com/support/docview.wss?uid=swg21976435&aid=1
Cognos 11.0.4 - https://www.ibm.com/support/knowledgecenter/SSEP7J_11.0.0/com.ibm.swg.ba.cognos.inst_cr_winux.doc/t_sso_actdirserver.html

(Note: When following the above technote, make sure that you use the port number of the application tier if you have a distributed install).



2. Common errors and Solutions.
1. HTTP 404 Unauthorized User Profile :caused by v1\login$ __NOT_TRANSLATED__(error404NotFound) User Profile Service : get v1/login
http://www.ibm.com/support/docview.wss?uid=swg21992690
http://www.ibm.com/support/docview.wss?uid=swg21997663
2. HTTP 441 - http://www.ibm.com/support/docview.wss?uid=swg21992587
3. HTTP 500 or Page Not Found error - http://www.ibm.com/support/docview.wss?uid=swg21992383
http://www-01.ibm.com/support/docview.wss?uid=swg21990857
http://www-01.ibm.com/support/docview.wss?uid=swg21989182

3. Changes to configuration from upgrade from R3 to R4. - https://www.ibm.com/support/knowledgecenter/SSEP7J_11.0.0/com.ibm.swg.ba.cognos.inst_cr_winux.doc/t_iis_1103_1104.html

4. Ensure in URIs in Cognos Configuration are using Fully Qualified Domain Names (FQDNs)

5. External Identity Mapping not working -
http://www.ibm.com/support/docview.wss?uid=swg21992853

(Please ensure appropriate tests with Internet Information Services admin are preformed to ensure the user being authenticated is the correct user.)


6. Ensure the webcontent/default.htm file is set up correctly - If you are not using the default alias name (ibmcognos) then you may have to make changes to default.htm.
1. On the Web Server machine, open the /analyticsInstallDirectory/webcontent directory in Windows Explorer.
2. Make a backup of the default.htm
3. Edit default.htm in a text editor.
4. Update the last entry to be similar to:
<meta http-equiv="refresh" content="0; URL=/<aliasName>/bi/">
7. Invalid Login Response - http://www.ibm.com/support/docview.wss?uid=swg22004766

 

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
26 May 2021

UID

swg21993357