IBM Support

ANR4588E - Database backup fails after changing the server or the BA client level

Troubleshooting


Problem

A server database backup may fail following a server upgrade or Backup/Archive client upgrade, or both. It can also happens when a new BA client is installed on the same system that the server is installed on.

Symptom

The database backup fails with the following error message in the activity log:

ANR4588E A database backup configuration might be incorrect.

Cause

Mismatched GSKIT level between the client and the server.

Diagnosing The Problem

Review the server activity log for the error message:

ANR4588E A database backup configuration might be incorrect.

For this problem to occur, the following conditions must be true:

1. The IBM Spectrum Protect server and the BA client are installed on the same system.

2. The versions of the server and the client contain different GSKIT levels. See the section "Resolving The Problem" for more detail on the GSKIT versions of the server and the client.

Resolving The Problem

The server and the client each includes its own GSKIT version. When there is a mismatch of the GSKIT versions between the client and the server, the database backup may fail. The following table includes the GSKIT version that is packaged with each server and client level. Compare your server and client level with this list. Do they have the same GSKIT version? If they don't, upgrade the client or the server so that the same GSKIT will be installed for both the server and the client.

IBM Spectrum Protect version GSKit version
7.1.1 8.0.14.43
8.0.50.31 (Mac, HP-UX)
7.1.2 8.0.50.40
7.1.3 8.0.50.44
7.1.3.2 (client)* 8.0.50.52
7.1.4 8.0.50.52
7.1.4.4 (client) 8.0.50.57
7.1.5 (server) 8.0.50.57
7.1.7.0 (server) 8.0.50.66
7.1.8.2 & 7.1.8.4 (client)

8.0.50.86

8.1.0 (client) 8.0.50.66
8.1.2 (client/server) 8.0.50.78
7.1.9 (server) 8.0.50.86
8.1.4 (client/server) 8.0.50.78
8.1.4.1 (client) 8.0.50.86
8.1.5 (server) 8.0.50.86
8.1.6 (client/server) 8.0.50.86
8.1.6.1 (client) 8.0.55.2

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version 7 and version 8","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM, Tivoli Storage Manager,

Document Information

Modified date:
16 May 2019

UID

ibm10719069