IBM Support

Purchase Order (PO) confirmShipment transaction is failing with Invalid Transaction error - YCP0063

Troubleshooting


Problem

The Purchase Order receiving process is failing with an error - "Invalid Transaction, Value="YCP0063", after the recent deployment.  There are no changes made to the Purchase Order flow as part of this deployment.

Error Details:

<Errors>
    <Error ErrorCode="YCP0063" ErrorDescription="Invalid Transaction" ErrorRelatedMoreInfo="">
        <Attribute Name="ErrorCode" Value="YCP0063"/>
        <Attribute Name="ErrorDescription" Value="Invalid Transaction"/>
        <Error ErrorCode="com.yantra.yfs.japi.YFSException" ErrorDescription="" ErrorRelatedMoreInfo="<?xml version="1.0" encoding="UTF-8"?>
</Errors>
<Error ErrorCode="YCP0063" ErrorDescription="Invalid Transaction" ErrorRelatedMoreInfo="">
<Attribute Name="ErrorCode" Value="YCP0063"/>
        <Attribute Name="ErrorDescription" Value="Invalid Transaction"/>
        <Attribute Name="BaseTransactionKey" Value="INCLUDE_IN_DERIVED_RDER"/>
        <Attribute Name="ProcessTypeKey" Value="PO_FULFILLMENT"/>
        <Stack>
        com.yantra.yfc.util.YFCException at com.yantra.omp.business.order.returns.OMPReturnOrderUtils.getReturnOrderDocType(OMPReturnOrderUtils.java:289) at com.yantra.omp.customdbhelper.YFSOrderLineGetXMLHelper.massageStandardGetXML(YFSOrderLineGetXMLHelper.java:628) at com.yantra.omp.customdb.YFS_Order_LineImpl.massageStandardGetXML(YFS_Order_LineImpl.java:2585) at com.yantra.omp.customdb.YFS_Order_LineImpl.getXML(YFS_Order_LineImpl.java:2784) at com.yantra.shared.dbclasses.YFS_Shipment_LineBase.getOrderLineXML(YFS_Shipment_LineBase.java:3667) at com.yantra.shared.dbclasses.YFS_Shipment_LineBase.getXML(YFS_Shipment_LineBase.java:3560) at com.yantra.ydm.customdb.YFS_Shipment_LineImpl.getXML(YFS_Shipment_LineImpl.java:553) at com.yantra.shared.dbclasses.YFS_ShipmentBase.getShipmentLinesXML(YFS_ShipmentBase.java:8667) at com.yantra.shared.dbclasses.YFS_ShipmentBase.getXML(YFS_ShipmentBase.java:8353)
        </Stack>

Cause

The YFS_TRANSACTION table is missing the required entry for a record. For example, using the Error stack outlined in the Problem the following keys are missing :
  • BaseTransactionKey: INCLUDE_IN_DERIVED_ORDER
  • ProcessTypeKey: PO_FULFILLMENT
This absence of  BaseTransactionKey and ProcessTypeKey causing the confirmShipment process to fail with the "Invalid Transaction" error.

Resolving The Problem

1) Run the following SQL query to confirm the presence of the transaction record:
SELECT * FROM OMDB.YFS_TRANSACTION  
WHERE BASE_TRANSACTION_KEY = 'INCLUDE_IN_DERIVED_ORDER'  
ORDER BY PROCESS_TYPE_KEY; 
2) Use the CDT Export from the working environment (that includes YFS_TRANSACTION table) and import it into lower environments (e.g., QA) for validation.
3) Validate the presence of the the transaction in Lower Environment by running the SQL from Step #1.
4) Ensure that the confirmShipment runs without issues.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cy00AAA","label":"Orders"}],"ARM Case Number":"TS017664230","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Product Synonym

oms; sterling oms; order management;

Document Information

Modified date:
09 April 2025

UID

ibm17185470