IBM Support

TM1 Architect freeze when adding CAM security groups

Troubleshooting


Problem

When opening the security/group menu in architect and right-clicking on add user/groups menu the application freezes and stop application is the only solution to resolve freeze issue.

Symptom

All functionalities are working fine except add CAM groups.

-the issue is only presented whit CAM authentication enabled, mode 1 is not impacted

-in client(architect ) logs there is no error.

-in tm1top there is no pending thread 

-add group via Ti process is working fine

-issue is reproducible for all instances (with CAM), all users

- in fiddler trace (How to perform Fiddler Trace to Capture Network Traffic (ibm.com)) when we exam traffic to Cognos Analytics  we can see 302 code

image-20240903113939-1

image-20240903114053-2

Cause

the issue is casued by the protocol missmatch 
In above scenarion the CAMurl was set to use http but CA was set to use https.

Resolving The Problem

Update tm1s.cfg to match protocol set in the CA.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m3p000000PC6lAAG","label":"Planning Analytics-\u003EArchitect"}],"ARM Case Number":"TS016406989","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
03 September 2024

UID

ibm17167084