IBM Support

Screen shrinks after opening java-related menu function - caused by limitation APAR PI94499

Troubleshooting


Problem

User launches 'main' Controller client. User maximises the Controller client (so its window size is full screen).

User then clicks any Java-related menu item (for example "Maintain  - Business Rules"). This causes the Controller screen to shrink (for example to 1/4 its original size).

If the user then tries to use some other menu items (for example 'Trial Balance with Drilldown') then some of the writing looks wrong (shrunk text / compressed fonts).

Symptom

Example #1

After clicking "Maintain - Business Rules" (or any other Java-related function)...

image-20180709125105-2

...the Controller window size immediately shrinks (for example to only a quarter of the size of the monitor):

image-20180709125332-4

Afterwards, if the user then tries to run some menu items (for example 'Trial Balance with Drilldown') then the fonts look wrong (squashed / shrunk / unreadable text):

image-20180709125613-6

Example #2

If the user does not open a JAVA-related menu item first, but instead runs a Trial Balance with Drilldown (TBwD) report, then the report appears correctly:

image-20180709130712-1

However, if the user now runs a JAVA-related menu item, then the TBwD report gets corrupted. Specifically, first the screen size shrinks:

image-20180709130904-2

Then the column for the 'Account Codes' becomes thinner (narrower) which chops off some of the text for the account code values:

Cause

Limitation (reference APAR PI94499) in Controller.

Environment

The problem is rare. It only occurs in very limited/specialised environments.

Example:

In one real-life case, the 'bad' user's client PC was running Windows 10, with 'Scale and layout' set to:

  • scale = 125%
  • resolution = 2560 x 1440

image-20180709131621-2

Resolving The Problem

Fix:
Perform the following on the client device:
1. Browse to the folder where the Controller client is installed
  • TIP: By default, this is here: C:\Program Files\IBM\IBM Cognos Controller Local Client
2. Right click on CCR.EXE
3. Click "Properties"
4. Click "Compatibility"
5. Click "Change settings for all users":
image-20191004154224-1
6. Click: Change high DPI settings
7. Tick the box:  Override high DPI scaling behavior
image-20191004154349-2
8. Modify the setting to be:   Scaling performed by: System (Enhanced)
9. Click OK, OK, OK
10. Test.
       
Workaround:

Exit Controller, and re-launch Controller.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
04 October 2019

UID

ibm10716705