Troubleshooting
Problem
User launches 'main' Controller client. User maximises the Controller client (so its window size is full screen).
User then clicks any Java-related menu item (for example "Maintain - Business Rules"). This causes the Controller screen to shrink (for example to 1/4 its original size).
If the user then tries to use some other menu items (for example 'Trial Balance with Drilldown') then some of the writing looks wrong (shrunk text / compressed fonts).
Symptom
Example #1
After clicking "Maintain - Business Rules" (or any other Java-related function)...
...the Controller window size immediately shrinks (for example to only a quarter of the size of the monitor):
Afterwards, if the user then tries to run some menu items (for example 'Trial Balance with Drilldown') then the fonts look wrong (squashed / shrunk / unreadable text):
Example #2
If the user does not open a JAVA-related menu item first, but instead runs a Trial Balance with Drilldown (TBwD) report, then the report appears correctly:
However, if the user now runs a JAVA-related menu item, then the TBwD report gets corrupted. Specifically, first the screen size shrinks:
Then the column for the 'Account Codes' becomes thinner (narrower) which chops off some of the text for the account code values:
Cause
Limitation (reference APAR PI94499) in Controller.
Environment
The problem is rare. It only occurs in very limited/specialised environments.
Example:
In one real-life case, the 'bad' user's client PC was running Windows 10, with 'Scale and layout' set to:
- scale = 125%
- resolution = 2560 x 1440
Resolving The Problem
- TIP: By default, this is here: C:\Program Files\IBM\IBM Cognos Controller Local Client
Exit Controller, and re-launch Controller.
Related Information
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Document Information
Modified date:
04 October 2019
UID
ibm10716705