Release Notes
Abstract
In an IBM Business Automation Workflow environment that uses an external IBM FileNet P8 Content Platform Engine (CPE), embedded rule deployment fails when you deploy your case management solution.
Content
Symptom
When you deploy your case management solution in Business Automation Workflow, you might see an error similar to the following error:
[6/22/18 12:37:14:086 CST] 000001c5 api E com.ibm.casemgmt.api error FNRPA0624E The rules could not be deployed because of the following error: An exception occurred in the event handler:
FNRPE0029E: [RULE_DEPLOYMENT_RULE_DEFINITION]: For case type CC_Compliant, exception occurred while converting following rule definition(s): CustomerRatingTable
com.ibm.casemgmt.intgimpl.deploy.handlers.ContinuableStepException: FNRPA0624E The rules could not be deployed because of the following error: An exception occurred in the event handler. Message was: FNRPE0029E: [RULE_DEPLOYMENT_RULE_DEFINITION]: For case type CC_Compliant, exception occurred while converting following rule definition(s): CustomerRatingTable
at com.ibm.casemgmt.intgimpl.deploy.handlers.ContinuableStepException.createContinuableStepException(ContinuableStepException.java:35)
Cause
The ODMMessages.jar file, required for the embedded Operational Decision Manager rules SDK, is missing from the CPE directory.
Resolving The Problem
Complete the following steps to copy the required file on your system before you reattempt solution deployment:
- Copy the ODMMessages.jar file from the Business Automation Workflow /opt/ibm/Workflow/v18.0/lib/ext to the external CPE directory at <WAS-home>/lib/ext home directory.
- Restart the external Content Platform Engine.
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Document Information
Modified date:
17 December 2021
UID
ibm10716505