IBM Support

Infosphere Guardium DataMart extracts failing after attaching Collector to multiple NAS devices.

Troubleshooting


Problem

Datamart extracts were running successful when mapping a central manager and its set of collectors to a single NAS (Network attached Storage) device. On the other hand, when pointing some of those same collectors to one NAS device and the remaining others to a second NAS device, the export fails. 

Symptom

On mapping the collectors to two different devices the, the export fails.

Cause

The debug log showed that the export failed because the password of the NAS account contained special characters. 

Other possible causes: Issue may also occur if all datamart jobs are run at the same time.

Diagnosing The Problem

Logs revealed that the export seemed to fail because the password of the NAS account contained special characters. 

On mapping the collectors to two different devices the, the following error was observed in the debug log:

==============Mon May 14 21:20:00 UTC 2018===================

Thread: DatamartCopyFile copyFile - destPass, dmin.error.export.specialchar.failed

============================================================

==============Mon May 14 21:20:00 UTC 2018===================

Thread: DatamartCopyFile copyFile - java.lang.NullPointerException

============================================================

============================================================

Resolving The Problem

Check password for special characters. 

!@#$%^&*()_+-={}[]:";'<>? 

If possible apply latest Guardium patch/GPU, which fixes the issue with special characters not being allowed. 

Another possible cause  for this error is that all datamart jobs are run at the same time. Reschedule the jobs to run at different timings to see if the files get send correctly.

This can be checked via:

   grdapi list_schedules

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Component":"Collector","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.1.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Product Synonym

failed export, Guardium

Document Information

Modified date:
22 August 2018

UID

ibm10716313