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Full Zipcode evaluation for inventory APIs

Question & Answer


Question

How do you ensure full US zip code for Inventory API are considered correctly  in IBM Sterling Order Management?

Cause

In case of scheduleOrder, the person_info record is read from DB but in case of get APIs it may not always be the case that yfs_person_info record is present.

 

Answer

Distance is not calculated when qualified US zip-codes as 33401-2302 for inventory APIs is passed. When 33401 zip code is used then distance is calculated accurately and appropriate node is identified. However for scheduleOrder API even if we pass the full zipcode as 33401-2302 the distance is calculated correctly and there is no issue.

Example Scenario:

  1. Setup a scheduling rule with optimization based on distance.

     
  2. Setup nodes - one in Florida and the other in California

     
  3. Adjust inventory for an item with 4 quantity in California and 1 quantity in Florida

     
  4. Invoke getFulfillmentOptionsForLines API with ShipToAddress\@ZipCode='33401-2302' and required quantity as 3.

     
  5. Expected Result - 1 quantity should be sourced from Florida. 2 quantity from California.
     

Actual Result - 3 Quantity is sourced from California because API considers distance from ShipTo to both the nodes is zero

In case of scheduleOrder, the person_info record is read from DB. This record will have both the qualified zipcode and  the short zip code populated and hence in scheduleOrder system is firing query including both of them.

For get API, please pass ShortZipCode as part of input XML to resolve this issue.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Component":"","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
29 June 2018

UID

ibm10715943