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AIUOM0006E: Unhandled error from licensing system, check server logs

Troubleshooting


Problem

When user tries to log to IBM Maximo Application Suite (MAS), an error "AIUOM0006E: Unhandled error from licensing system, check server logs" is displayed.

Symptom

During the MAS login, an error "AIUOM0006E: Unhandled error from licensing system, check server logs" is displayed.
In the licensing-mediator pod logs, in the MAS core namespace, you see an error:
"2024-06-18 16:00:00,592 licensing_mediator ERROR Unable to initialize client and utilities: An unhandled error was returned from SLS: HTTPSConnectionPool(host='<SLS URL>', port=443): Max retries exceeded with url: /api/probes/readiness (Caused by SSLError(SSLEOFError(8, 'EOF occurred in violation of protocol (_ssl.c:1129)')))"
In the api-licensing pod logs, in the sls namespace, you see an error:
"[14/06/2024, 04:28:23:989 UTC] 0000003d id=00000000 SystemErr R com.mongodb.MongoTimeoutException: Timed out after 30000 ms while waiting to connect. Client view of cluster state is {type=UNKNOWN, servers=[{address=<MONGODB_HOSTNAME>:<MONGODB_PORT>, type=UNKNOWN, state=CONNECTING, exception={com.mongodb.MongoSocketException: <MONGODB_HOSTNAME>}, caused by {java.net.UnknownHostException: <MONGODB_HOSTNAME>}}]"

Cause

The api-licensing pod is unable to connect to the mongo database.

Resolving The Problem

After making sure that the mongo database is up and running, restart the api-licensing pod.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m0z000000cwZDAAY","label":"Maximo Application Suite"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
26 June 2024

UID

ibm17158805