Troubleshooting
Problem
The following error can occur for the first user who attempts to log in to Maximo Mobile after a server restart.
The server is correct, but the app is not available. Contact your Administrator
Subsequent attempts to use Maximo mobile work until the server is restarted, when the problem could return.
Symptom
Error: The server is correct, but the app is not available. Contact your Administrator
Cause
Time is needed for caching for the first attempt to reach http(s)://maximoserver/maximo/api/graphite/mobile/packages/MOBILELOGIN. When the request times out, the error appears.
Diagnosing The Problem
Steps to reproduce:
1. In Maximo Mobile select Reset app
1. In Maximo Mobile select Reset app
2. Restart the Maximo server
3. Launch Maximo Mobile and enter Maximo URL
3. Launch Maximo Mobile and enter Maximo URL
Actual Result: Error appears
Expected Result: After URL is entered it should proceed to login.
Resolving The Problem
When the first person logs in there is a lot of caching that occurs. All subsequent attempts to use Maximo mobile for the same user and other users are successful. If the user did not reset their app and has access Maximo mobile before, the error does not appear.
Workaround:
Access the following URL from a browser after restart.
The http(s)://maximoserver/maximo/api/graphite/mobile/packages/MOBILELOGIN request is taking 30+ seconds after the restart.
Document Location
Worldwide
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Document Information
Modified date:
20 June 2024
UID
ibm17157103