IBM Support

Unable to access OMoC DTK MQ console

Troubleshooting


Problem

Installed an OMoC DTK on a Windows 11 workstation with WSL enabled.  OMS consoles(smcfs, sbc,sma etc) are working with the host browser, however the MQ console page(https://localhost:9444/ibmmq/console/login.html) returns error "Hmmm… can't reach this page It looks like localhost closed the connection"

Symptom

The OMoC DTK MQ console page(https://localhost:9444/ibmmq/console/login.html)  returned the following error:
Hmmm… can't reach this page It looks like localhost closed the connection
Try:
Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_CLOSED

Cause

MQ console web server is started automatically when boot up of the MQ docker container(om-mqserver).  Howver sometime the MQ web server failed to complete the startup process and requires a restart.

Environment

Windows 11 with WSL

Diagnosing The Problem

Use the following command to check if the MQ console wev server(mqweb)has been started or not with the DTK om-mqserver container.
docker exec om-mqserver ps -ef|grep mqm
mqm          305       1  0 19:19 ?        00:00:00 /opt/mqm/bin/amqzxma0 -m OM_QMGR -u mqm
mqm          317     305  0 19:19 ?        00:00:00 /opt/mqm/bin/amqzfuma -m OM_QMGR
mqm          322     305  0 19:19 ?        00:00:00 /opt/mqm/bin/amqzmgr0 -m OM_QMGR
mqm          325     305  0 19:19 ?        00:00:00 /opt/mqm/bin/amqzmuc0 -m OM_QMGR
mqm          446     305  0 19:19 ?        00:00:00 /opt/mqm/bin/amqzmur0 -m OM_QMGR
mqm          461     305  0 19:19 ?        00:00:00 /opt/mqm/bin/amqzmuf0 -m OM_QMGR
mqm          479     305  0 19:19 ?        00:00:00 /opt/mqm/bin/amqrrmfa -m OM_QMGR -t2332800 -s2592000 -p2592000 -g5184000 -c3600
mqm          485     322  0 19:19 ?        00:00:00 /opt/mqm/bin/amqpcsea OM_QMGR
mqm          486     322  0 19:19 ?        00:00:00 /opt/mqm/bin/runmqchi -m OM_QMGR -q SYSTEM.CHANNEL.INITQ -r
mqm          497     305  0 19:19 ?        00:00:00 /opt/mqm/bin/amqzlaa0 -mOM_QMGR -fip0
mqm          499     461  0 19:19 ?        00:00:00 /opt/mqm/bin/amqfqpub -mOM_QMGR
mqm          502     322  0 19:19 ?        00:00:00 /opt/mqm/bin/runmqlsr -r -m OM_QMGR -t TCP -p 1414
mqm          534     499  0 19:19 ?        00:00:00 /opt/mqm/bin/amqfcxba -m OM_QMGR
The above running process list shows no running mqweb server process like the following:
mqm        589     1  0 May24 ?        00:19:33 /opt/mqm/java/jre64/jre/bin/java -javaagent:/opt/mqm/web/bin/tools/ws-javaagent.jar -Djava.awt.headless=true -Djdk.attach.allowAttachSelf=true -Djdk.tls.ephemeralDHKeySize=2048 -Djdk.tls.disabledAlgorithms=SSLv3, TLSv1, TLSv1.1, RC4, MD5withRSA, DH keySize < 768, 3DES_EDE_CBC, DESede, EC keySize < 224, SHA1 jdkCA & usage TLSServer -Dfile.encoding=UTF-8 -Dcom.ibm.jsse2.renegotiate=DISABLED -jar /opt/mqm/web/bin/tools/ws-server.jar mqweb

Resolving The Problem

Use the following commands to stop then restart the MQ server in DTK:

docker exec -u mqm om-mqserver /opt/mqm/bin/endmqweb

docker exec -u mqm om-mqserver /opt/mqm/bin/strmqweb

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cy00AAA","label":"Orders"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.0.0"}]

Document Information

Modified date:
25 June 2024

UID

ibm17155001