IBM Support

Resolving Integrity Checker error BMXAA0458E

Troubleshooting


Problem

Integrity Checker reports error:
BMXAA0443E -- Error - BMXAA0458E -- The following user groups were not found in the MAXGROUPS table. Run the Integrity Checker in repair mode.
  BMXAA6837I -- User: MXINTADM Group: MAXADMIN
  BMXAA6837I -- User: MAXREG Group: MAXEVERYONE
  BMXAA6837I -- User: MXINTADM Group: MAXEVERYONE

Cause

Unknown. Integrity Checker may have previously been run in Repair Mode. In any case, their presence does not affect Maximo security.

Diagnosing The Problem

Run the SQL select here, putting into the parentheses the userids listed in the error:
Select *
 From maxuser
 Where userid
 In ('MAXADMIN', 'MAXREG', 'MXINTADM') ;
Select userid, groupname
 From groupuser
 Where groupname = 'MAXEVERYONE';

Resolving The Problem

Do not run Integrity Checker in Repair Mode.
  • Contact someone who uses these Preventive Maintenance and Scheduler applications to determine if the data is useful or not.
  • Any Work Order Generation in process should be completed before shutting down and upgrading the database; that is, the table should be empty.
  • Back up of the database
  • Delete all records in the WOGEN table.
  • Run Integrity Checker in Report Mode again to confirm that the error is no longer written to the log file.

Document Location

Worldwide

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Document Information

Modified date:
24 May 2024

UID

ibm17154589