Troubleshooting
Problem
When installing a Guardium patch, the installation process may not complete or may appear to get stuck. No error is thrown.
Symptom
Patch installation running for hours and does not result in a completion. It appears stuck at a post install step.
Cause
The patch installation process can be interrupted if quick search is enabled on the appliance.
Environment
v11.4 and above
Diagnosing The Problem
Check the patch installation progress with the command show system patch installed.
You may find the patch installation is stuck at "STEP: Executing Post Install Actions" for hours.
Example:
485 CLI Update Bundle for GPU 400 (Nov 2024-04-26 11:46:04 STEP: Executing Post Install Actions
Resolving The Problem
Once the issue has been diagnosed, please perform these steps:
- Delete the patch using the command and delete scheduled-patch enter the stuck patch number.
- Disable quick search using the command: grdapi disable_quick_search
- Reapply the patch and monitor patch status to completion.
If issue persists, please raise a support case with IBM support.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"ARM Category":[{"code":"a8m0z000000Gp0NAAS","label":"INSTALL UPGRADE MIGRATION"},{"code":"a8m3p000000PCTuAAO","label":"Platform\/Installation\/Deployment"}],"ARM Case Number":"TS016089594","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
02 May 2024
UID
ibm17150057