Troubleshooting
Problem
Symptom
![Loading](/support/pages/system/files/inline-images/loading-error.png)
Cause
am.properties file is missing from \server\conf\ccm folder
Possible cause 2:
am.properties file exists, but the file does not have a property with the key 'com.ibm.team.rmm.oslc.rm_app_config'
Possible cause 3:
am.properties file and the property with the key 'com.ibm.team.rmm.oslc.rm_app_config' exist, but the value of this property is empty or 'invalid'
Diagnosing The Problem
1. Check if am.properties exists under the location on the RMM sever:
<server_install_location>\server\conf\ccm\
2. Open am.properties and check if the property with the key 'com.ibm.team.rmm.oslc.rm_app_config' exists
3. Open am.properties and check if the property with the key 'com.ibm.team.rmm.oslc.rm_app_config' has a valid value
Resolving The Problem
1. Make sure that am.properties exists and com.ibm.team.rmm.oslc.rm_app_config key have a valid value
This file can be copied from any other RMM server or it can be created with the following contents:
com.ibm.team.rmm.oslc.rm_app_config={"Configuration":{"tool":{"path":"configuration"},"format":{"date":"%1$tb %1$td, %1$tY, %1$tI:%1$tM:%1$tS %Tp"}},"Default DOORS":{"tool":{"path":"dwa"},"attributes":{"Title":{"property":"Title"},"RequirementId":{"property":"Absolute Number"},"Specification":{"property":"Object Text"},"Description":{"property":"Object Short Text"}},"tags":{}},"Default DOORS Next":{"tool":{"path":"rm"},"attributes":{"Title":{"format":{"format":"%1$s: %2$s","limit":"50","values":[{"propertyUri":"http://purl.org/dc/terms/identifier","property":"Identifier"},{"propertyUri":"http://purl.org/dc/terms/title","property":"Title"}]}},"RequirementId":{"propertyUri":"http://purl.org/dc/terms/identifier","property":"Identifier"},"Specification":{"propertyUri":"http://www.ibm.com/xmlns/rdm/types/PrimaryText","property":"Primary Text"},"Description":{"propertyUri":"http://purl.org/dc/terms/description","property":"Description"}},"tags":{}},"Default ETM":{"tool":{"path":"qm"},"attributes":{"Title":{"format":{"format":"%1$s: %2$s","limit":"50","values":[{"propertyUri":"http://open-services.net/ns/core#shortId","property":"Short ID"},{"propertyUri":"http://purl.org/dc/terms/title","property":"Title"}]}},"RequirementId":{"propertyUri":"http://open-services.net/ns/core#shortId","property":"Short ID"},"Description":{"propertyUri":"http://purl.org/dc/terms/description","property":"Description"}},"tags":{}},"Default EWM":{"tool":{"path":"ccm"},"attributes":{"Title":{"format":{"format":"%1$s: %2$s","limit":"50","values":[{"propertyUri":"http://open-services.net/ns/core#shortId","property":"Short ID"},{"propertyUri":"http://purl.org/dc/terms/title","property":"Summary"}]}},"RequirementId":{"propertyUri":"http://open-services.net/ns/core#shortId","property":"Short ID"},"Description":{"propertyUri":"http://purl.org/dc/terms/description","property":"Description"}},"tags":{"Type":{"propertyUri":"http://jazz.net/xmlns/prod/jazz/rtc/cm/1.0/type","property":"Type"},"Priority":{"propertyUri":"http://open-services.net/ns/cm-x#priority","property":"Priority"},"Status":{"propertyUri":"http://jazz.net/xmlns/prod/jazz/rtc/cm/1.0/state","property":"Status"}}}}
2. Restart the server
Note: More information on Customizing the information displayed for remote artifacts
Note: It is also possible to customize this per Rhapsody client (without changing a file on the server that would change this appearance for all users).
Document Location
Worldwide
Was this topic helpful?
Document Information
Modified date:
10 May 2024
UID
ibm17150053