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User consume more App Points than shown in MAS UI

Troubleshooting


Problem

The license usage report shows more app points reserved than assigned to the users.

Symptom

The license usage report shows more app points reserved than assigned to the users.

Cause

The licensing sync job does not run as scheduled.
The licensing sync job runs every 30 minutes.
In MAS 8.11.5 a new job was introduced to execute the licensing sync. In previous version the job was executed by the licensing mediator pod.

Diagnosing The Problem

In MAS version pror to 8.11.5, in the licensingmediator pod you see entry like:
2024-04-04 06:51:40,648 apscheduler.scheduler WARNING Execution of job "LicensingSync.sync (trigger: interval[0:30:00], next run at: 2024-04-04 06:51:40 UTC)" skipped: maximum number of running instances reached (1) 2024-04-04 06:51:40,649 apscheduler.scheduler DEBUG Next wakeup is due at 2024-04-04 07:21:40.645441+00:00 (in 1799.996733 seconds)
In later versions, check the licensing sync pod logs for errors.
In the sls database in MongoDB, in the licenses collection, you see some duplicate entries for the same user, one entry for the username and one for the userId.
Note that the licensing sync should merge all records for one environment for the same users into one entry, and for other environments if the license assignment is the same.

Resolving The Problem

Restart the licensing mediator pod.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hB8ZAAU","label":"Maximo Application Suite-\u003EInstallation-\u003EIBM SLS"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
24 April 2024

UID

ibm17149200