Troubleshooting
Problem
When trying to configure email fn_outbound_email to work in Cloud Pak for Security (CP4S) [now known as QRadar Suite], we get authentication failed error:
"An error occurred while sending the email: (535, b'Authentication credentials invalid')"
"An error occurred while sending the email: (535, b'Authentication credentials invalid')"
Cause
The 535 errors are coming back from you SMTP server and would suggest a problem with the credentials used. If this happened with no changes being made to the app.config, then could the problem be an AD/SMTP account.
Diagnosing The Problem
You could try using curl to send an SMTP email using the same credentials as the app. You could run this from the App Host server to try sending an attachment to an email address:
curl --ssl smtp://mail.example.com --mail-from self@example.com \
--mail-rcpt receiver@example.com --upload-file email.txt \
--user 'user@account.com:your-password'
Note: An example
email.txt
could look like this:
From: John Doe <john@example.com>
To: Jane Doe <jane@example.com>
Subject: an example email
Date: Wed, 7 Mar 2024 16:07:00
How you doing?
If it fails using the same credentials configured in the app.config, it would suggest a username and password problem.
Resolving The Problem
- Verify the credentials are valid.
- Verify the email account has not expired.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
27 March 2024
UID
ibm17145396