IBM Support

IBM DOORS Client error "The connection with the database server has been lost and reconnection attempts have failed."

Troubleshooting


Problem

1- The DOORS Database Server service remains in "Stopping" state and requires to manually kill the process
2- The users cannot perform an archive or restore of a module or project. The archive process hangs followed by error:
The connection with the database server has been lost and reconnection attempts have failed.

Symptom

Users are able to use the DOORS application however, certain functionality such as Archiving or editing a module causes the DOORS Client application to crash.

Cause

The issue is caused by previously set password on DOORS database server. The error occurs after upgrading DOORS database server from older version to 9.7.2.8.
This is identified as Known Issue (Defect) #DT365624

Environment

Windows
Linux

Diagnosing The Problem

1. Launch DOORS Client
2. Perform an archive of a module
3. Archive process freezes followed by DOORS Client session crash
Restarting DOORS Database Server service remains in "Stopping" state and requires to manually kill the task.

Resolving The Problem

Resolving the issue, the database password needed to be reset.

1- Ensure all the users are logged out of DOORS session
2- Stop DOORS Database Server service (Service Name: DOORS DB Server 9.7)
3- Navigate to DOORS\data directory. For example: C:\Program Files (x86)\IBM\Rational\DOORS\9.7\data
4- Rename following file
dbdata.dtc to dbdata.dtc.old
dbdata.lck to dbdata.lck.old
4- Start DOORS Database Server service (Service Name: DOORS DB Server 9.7)
5- Launch DOORS Database Server Administration Tool and Refresh without password to confirm password is not required
6- You can now set a new password for DOORS Database server using DOORS Database Server Administration Tool
  • Click Change Password
  • Provide a new password and select OK
  • Restart DOORS Database service (Service Name: DOORS DB Server 9.7)
7- Launch DOORS Client and perform an archive again
You may also contact IBM Rational Support for resetting Database Server password. [Submit a Service Request (SR)]

Document Location

Worldwide

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Document Information

Modified date:
28 March 2024

UID

ibm17145308