IBM Support

ローカル・コンピューター上の Engineering Lifecycle Management は起動して停止しました

Troubleshooting


Problem

サービス化して自動開始にしている「Engineering Lifecycle Management」が開始されておらず、サービスを手動で開始しようとした際にエラーが発生しました。
「ローカル・コンピューター上の Engineering Lifecycle Management (ELM702) は起動して停止しました。サービスの中には、ほかのサービスやプログラムで使用していない場合は自動的に停止するものがあります。」

Symptom

Windows message

Cause

この問題はよくサーバーのポート番号競合の場合、発生します。この現象が考えられます。
1) すでに中途半端に起動中の IBM WebSphere Application Server Liberty インスタンスが存在します。
2) サーバーが起動時に使用しようとしているポートの一つが他の製品で使用中です。
3) ウイルスソフトや暗号化のソフトが存在した場合、サーバーの起動が邪魔されています。

Environment

Engineering Lifecycle Management 同梱の IBM WebSphere Application Server Liberty は Windows サービスによって起動するように設定されています。

Diagnosing The Problem

詳細のメッセージは [コントロールパネル] > [管理ツール] > [イベントログ] で記録されているかどうか確認します。
Address already in use by another process.
Run 'netstat -o -n -a' from a command line to find the conflicting
process ID, then look in Task Manager to find the name of that process.

アプリケーション・サーバーより ISADC のログも取得します。messages.log、あるいは、問題のアプリケーションのログでエラーが記録されていますでしょうか。

この質問を尋ねることをお勧めします。
  • 最近新しいソフトを同じ環境に導入されていますでしょうか。
  • 問題が発生し始めた日時の直前、どのような環境変更がありましたでしょうか。
  • サービスによる起動は以前正常に動作していましたでしょうか。

Resolving The Problem

1) サービスが起動しない環境の OS 再起動を行います。
このことによって思わずインスタンスがすでに起動されている場合、ポートが解放されるはずです。
2) 競合しているアプリケーションのプロセス ID を探します。
再起動で状況が改善しない場合、コマンド行より netstat -o -n -a を実行します。ポート 443、9443、など同じポートを使用する項目がありますでしょうか。タスクマネージャーからどのプロセスがその PID なのかを把握します。なお、サーバーが起動するときに使用するポートは server.xml に書かれています。
3) 他のアプリケーションが原因なら、使用されるポートを変更するかアプリケーションを停止する必要があります。(ELM のポート番号は JTS セットアップを行う前だけ変更可能です。)ウイルスソフトや暗号化のソフトが存在した場合、Liberty サーバーのパスを対象外に設定することをお勧めします。

Document Location

Worldwide

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Product Synonym

JTS

Document Information

Modified date:
29 February 2024

UID

ibm17128050