Troubleshooting
Problem
When you open any Role Based Application on Mobile 8.10 and Mobile 8.11 you can see this error message in your Maximo SystemOut Log:
[2/13/24 11:36:03:310 BRST] 00000145 SystemOut O 13 Feb 2024 11:36:03:288 [ERROR] [MAXIMO] [CID-MXOSLC-411] null
java.lang.NullPointerException: null
at com.ibm.tivoli.maximo.oslc.provider.MaximoOslcProviderServlet.handleRoute(MaximoOslcProviderServlet.java:1301) ~[commonweb.jar:?]
at com.ibm.tivoli.maximo.oslc.provider.MaximoOslcProviderServlet.doGet(MaximoOslcProviderServlet.java:716) [commonweb.jar:?]
at javax.servlet.http.HttpServlet.service(HttpServlet.java:687) [javax.j2ee.servlet.jar:?] at javax.servlet.http.HttpServlet.service(HttpServlet.java:790) [javax.j2ee.servlet.jar:?]
at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1235) [com.ibm.ws.webcontainer.jar:?]
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:779) [com.ibm.ws.webcontainer.jar:?]
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:478) [com.ibm.ws.webcontainer.jar:?]
at com.ibm.ws.webcontainer.servlet.ServletWrapperImpl.handleRequest(ServletWrapperImpl.java:179) [com.ibm.ws.webcontainer.jar:?]
at com.ibm.ws.webcontainer.filter.WebAppFilterChain.invokeTarget(WebAppFilterChain.java:143) [com.ibm.ws.webcontainer.jar:?]
at com.ibm.ws.webcontainer.filter.WebAppFilterChain.doFilter(WebAppFilterChain.java:96) [com.ibm.ws.webcontainer.jar:?]
at com.ibm.tivoli.maximo.filter.UnSupportedMethodBlockFilter.doFilter(UnSupportedMethodBlockFilter.java:60) [commonweb.jar:?]
at com.ibm.ws.webcontainer.filter.FilterInstanceWrapper.doFilter(FilterInstanceWrapper.java:197) [com.ibm.ws.webcontainer.jar:?]
at com.ibm.ws.webcontainer.filter.WebAppFilterChain.doFilter(WebAppFilterChain.java:90) [com.ibm.ws.webcontainer.jar:?]
This doesn't cause any error for any Mobile Application and you can only see this error in the Maximo log.
Symptom
java.lang.NullPointerException in the Maximo SystemOut log.
Cause
The problem happens when mobile tries to get a response for this request:
This causes this error:
{ "Error": { "reasonCode": null, "message": "BMXAA1649E - A programming error resulted in a null pointer exception.", "statusCode": "500" }
And causes the java.lang.NullPointerException in the Maximo logs.
This request for /maximo/oslc/permission/modules is just a check to list the apps that are available for the user, Mobile doesn't use this information and has not effects in any application.
Environment
Mobile for EAM 8.10 and 8.11
Diagnosing The Problem
You can execute this request on your Maximo environment and log at the Maximo logs at the same time, the error will happen.
Resolving The Problem
There's no fix for this on Mobile EAM versions, this message can be ignored and this is resolved on MAS/Manage versions where the request works and doesn't cause any error in the logs.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAgaAAE","label":"Maximo Application Suite-\u003EMAS Applications-\u003EMobile"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.10.0;8.11.0"}]
Product Synonym
mobile for eam; mobile; null pointer
Was this topic helpful?
Document Information
Modified date:
23 February 2024
UID
ibm17123191