IBM Support

BMXAA6416E - The property mci.mvi.apiurl : (null) was not found in the properties file.

Troubleshooting


Problem

This is a problem that happens every time that you try to open the Inspection Role Based Application or connect Mobile for EAM to Maximo.
This message is displayed:
error

Symptom

Once you open the Inspection Role Based Application or connect Mobile for EAM to Maximo, this error will be displayed.
This doesn't cause any error to any Applications, but this keeps being displayed for the end user.

Cause

This is caused by Mobile checking for the system properties mci.mvi.apiurl and mci.mvi.apikey on Maximo even if you don't have Maximo Civil Infrastructure installed.

Environment

Maximo TPAE prior to IFIX 16, so IFIX 15 or lower with Mobile for EAM 8.10 IFIX 9 or Mobile for EAM 8.11 IFIX 4

Diagnosing The Problem

This happens in every platform (iOS, Android and Windows) using Mobile for EAM app or in any browser after opening Inspection Role Based Application.

Resolving The Problem

This is fixed by DT243499 that is included on IFIX 16, it basically removes the check for these 2 properties.

Here's the IFIX list:

https://www.ibm.com/support/pages/finding-maximo-7613-interim-fix-version

The IFIX 16 download page:

https://www.ibm.com/support/pages/node/7113802

This is the defect that fixes the issue:

https://www.ibm.com/mysupport/s/defect/aCI3p0000004Kmi/dt243499?language=en_US

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAgaAAE","label":"Maximo Application Suite-\u003EMAS Applications-\u003EMobile"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.10.0;8.11.0"}]

Product Synonym

mobile; mobile for eam

Document Information

Modified date:
23 February 2024

UID

ibm17123186