IBM Support

Grand Total not getting updated in the return order in IBM Sterling Order Management System

Troubleshooting


Problem

On creating a return order, it is observed that the line total is displaying the correct price but the order total is not considering the line price.

Cause

There can be other causes for this issue but one of the most frequently encountered being return order line is created with IsLinePriceForInformationOnly flag set to Y.

Resolving The Problem

If the return order line price needs to be considered in the Order Total, then IsLinePriceForInformationOnly flag should be set to 'N' in the API input of createOrder or changeOrder API while creating the line. Please refer to the API java docs for these APIs which has more details regarding the flag.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Maintenance","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.3;9.4;9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
21 June 2018

UID

swg22012453