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Users are getting logged out of MAS Manage when SAML is enabled, error code 0

Troubleshooting


Problem

On MAS Manage with SAML enabled, users who are actively working in Manage are getting logged out. 

 

Cause

When MAS Manage is idle, the screen will time out.
When logging back in, 2 user sessions are created. 
When one of the sessions expires, the other then results in timeout while working in Manage.

Resolving The Problem

To address this issue, you can follow these steps:
1 - Log into MAS as an administrator.
2 - Click on the Administration cog wheel in the header bar.
3 - From the Suite Administration menu click the Workspace link.
4 - In the My Workspace page, click the Manage Application.
5 - In the Manage Workspace, click the Actions drop down located at the top right corner and select Update Configuration.
6 - In the Update Manage Configurations dialog under the list of Configurations select the Server bundles link.
7 - In the Update Manage workspace configuration page go to the Server bundles section.
a- You will see a list of bundles.
b - Click the View link for the UI bundle.
c - The Additional server bundle properties dialog will appear.
d - In the Additional server config field add the following if no existing secret exists:
<server description="new server"> <httpSession cookieName="JSESSIONIDUI" cookieSecure="true" invalidateOnUnauthorizedSessionRequestException="true" invalidationTimeout="12h" cookieSameSite="Lax"/> </server>
If secret exists:
The following entry should be added into the server xml reference for the referenced secret right before the
</server> end tag. <httpSession cookieName="JSESSIONIDUI" cookieSecure="true" invalidateOnUnauthorizedSessionRequestException="true" invalidationTimeout="12h" cookieSameSite="Lax"/>
8. Save and activate the changes.

Document Location

Worldwide

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Document Information

Modified date:
08 February 2024

UID

ibm17116228