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Push notifications fail to send after upgrading to Maximo Application Suite 8.11

Troubleshooting


Problem

Mobile notifications are no longer received after upgrade to Maximo Application Suite 8.11

Symptom

 The notifications are sent outbound through the queues in Manage but never reach the destination user.

Cause

This issue is caused by a change in the URL of the push notification service.

Diagnosing The Problem

To determine whether the cause of your problem is an incorrect URL for the notification service, you can review the push notification service pod logs for the following error.
 
error AxiosError: Request failed with status code 429
    at settle (/usr/push-notification-service/src/mas/node_modules/axios/dist/node/axios.cjs:1913:12)
    at IncomingMessage.handleStreamEnd (/usr/push-notification-service/src/mas/node_modules/axios/dist/node/axios.cjs:2995:11)
    at IncomingMessage.emit (node525:35)
    at endReadableNT (node:internal/streams/readable:1358:12)
    at processTicksAndRejections (node:internal/process/task_queues:83:21) {
  code: 'ERR_BAD_REQUEST',The response is showing the following for the too many requests, which is stating allowed 0.    data: {
      code: 'A0uLzTBnKskPvsGaDnxGYrOonCWAOHOU',
      error: 'Too many requests in the last minute (count: 2, allowed: 0).'
    }

Resolving The Problem

To resolve the issue, update your URL in the Maximo Application Suite push notification configuration.
 
1. Open Maximo Application Suite and click Admin
2. Click Configurations then Push Notifications
3. The incorrect URL from the previous version is https://c069b665.us-south.apigw.appdomain.cloud/auth/login
4. Update the existing url to https://pushnotification.suite.maximo.com/pushnotification/sendMessage

Document Location

Worldwide

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Document Information

Modified date:
01 February 2024

UID

ibm17114248