IBM Support

Rational DOORS: Unable to delete a project that is from a failed archive restore

Troubleshooting


Problem

Unable to delete a Project even with Administrator Login Account.

Symptom

Receive error when deleting a project:


Deletion of [..Project Name...] project failed. Insufficient access.

Cause

Project failed to restore from an archive.

Environment

Windows

Diagnosing The Problem

First, is to verify the access rights against every object inside this project, such as folder or module or even requirements. Make sure the user who is trying to delete the project has Deletion rights to everything inside the project.

If the project is created from an archive restore, you will have to work around for the project delete.

Resolving The Problem

To work around this issue, rename the existing project .mod folder to something else. For example, if the mod folder name m0000190a.mod, rename it to m0000190a.mod.old.

Then, run the database integrity from the parent of this problem project to locate the empty folder and delete it from the lost and found folder. The project should disappear from the database view. Now we can get back to the project mod folder location and delete the m0000190a.mod.old folder.

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5;9.6;9.6.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21990891