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What actions can make a Cognos administrator license count?

Question & Answer


Question

What actions can make a Cognos Administrator license count to be larger than expected?

Cause

1.) The user account has any one of the capabilities listed under the Analytics Administrator role (especially the Specification Execution capability, as this is know to put the user in the Analytics Administrator license role)
2.) The Everyone Group is part of the System Administrator role
3.) The user has left the organization and has been removed from company AD/LDAP, but their profile and license still exist in Cognos content store.

Answer

1.) Remove any of the unwanted administrator capabilities from the user who do not require them:  
  1. Select Manage > People > Capabilities to see the complete list of capabilities.
2.) Remove the Everyone Group from the built in licensed Cognos System Administrators role:
  1. Log on with your personal userid, which you previously assigned to the System Administrators role.
  2. Click Manage > People > Accounts.
  3. Select the Cognos namespace.
  4. Click the More icon More icon next to the System Administrators role and then click View members.
  5. Click the Remove member icon Remove member icon next to Everyone group and then click OK.
3.) In most cases running the Consistency check with the "Find and Fix" option should help with resetting the License Count.  NOTE: you must be logged into ALL available namespaces BEFORE running the task:
  1. In IBM Cognos Administration, on the Configuration tab, click Content Administration.
  2. Click the new content maintenance icon in the toolbar, and then click Consistency Check.
  3. Type the task name, and optionally a description and screen tip.
  4. Click Internal references to check the content store for inconsistencies.
  5. Choose how to run the task:
    • To run the task now or later, click Save and run once. Specify a time and date for the run. Click Find only, and then click Run. Review the run time and click OK.
    • To save the task without scheduling or running, click Save only.
 You can also delete individual user profiles from the Cognos Administration namespace, then refresh Global License Usage:
  1. In IBM Cognos Administration, on the Security tab, click Users, Groups, and Roles.
  2. Click the namespace that contains the user.
  3. Find the user whose user profile you want to delete. You can use the Search feature to find a user.
  4. In the Actions column, click More.
  5. Click Delete this user's profile.
  6. Click OK.
  7. Go to Manage > Licenses and click the Refresh link

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Document Information

Modified date:
24 April 2024

UID

ibm17109939