IBM Support

Maximo Mobile - Missing applications

Troubleshooting


Problem

After upgrading from MAS 8.9 to MAS 8.10, Maximo Mobile does not download any applications.

Symptom

When trying to log in to Maximo Mobile app (for MAS) on a mobile device, no applications download.
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Resetting the app does not help.
Data update view does not show any error
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Cause

Login as the mobile user from browser.  Open a new browser tab and check the user profile by using the API query:

https://api.MAS_URL/profile?workspaceId=workspace_ID

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The workspace is blank.  It indicates that the user does not belong to any workspace.

Mobile user needs to belong to a workspace with access to applications e.g. Manage, assist, monitor

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Diagnosing The Problem

  • Resetting the app does not help.
  • No error in the debug device log and coreapi logs.
  • Mobile user can view data from role-based applications and other Manage applications. 
User has permission to technician application
image-20240110150646-8
  • New users could access applications in the Maximo Mobile app. 

But old users that exist prior to the upgrade could not access applications in the Maximo Mobile app.

  • Check the Admin workspace in MAS (Maximo Application Suite).  Select Users in the left panel.image-20240110145315-6

Select a mobile user.  The application access section is blank.   Mobile user no longer has access to applications after MAS upgrade.

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Check the application access for other users.  Old users do not have access to applications.

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Only new users have application access and all the applications display on the mobile device.

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Resolving The Problem

Click the edit button from the "View User" page in the admin workspace
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Application access section shows the "Manage with Health" application. 
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Click the down arrow next to the "Select role" and select "Set in Manage".
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All users can see applications in Maximo Mobile after granting access to Manage from admin workspace in MAS.
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Document Location

Worldwide

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Document Information

Modified date:
10 January 2024

UID

ibm17106758