IBM Support

Dashboard display is empty. Only showing blank pages and getting 404 error.

Troubleshooting


Problem

The Control Center Web Console is not display data for the monitored servers.  HTTP 404 error is displayed

Symptom

The HTTP 404 Not Found response status code indicates that the server cannot find the requested resource. Links that lead to a 404 page are often called broken or dead links and can be subject to link rot.

Cause

There was an issue with the database connection to the Web Console and the Web Console did not recover from the database outage.

Diagnosing The Problem

HTTP 404 shown on the Web Console
Database errors in the web logs are repeating.

Resolving The Problem

Stop and Start Control Center to restart the Web Services.
Verify in the Control Center fix list for the version you are running has IT41237/MFT-13392 (2022-06-14) installed.
Description of fix: Implemented a process that runs in the engine and detects if the DB server had been down. With this fix, when the DB server is restarted, the web server will be restarted to reinitialize the web applications to properly re-establish database connections. This feature is turned off by default. It must be turned on via engine.properties: <ENABLE_DB_SERVER_STATUS_CHECKER>true</ENABLE_DB_SERVER_STATUS_CHECKER>

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSJC3O","label":"IBM Sterling Control Center Monitor"},"ARM Category":[{"code":"a8m0z000000cwWHAAY","label":"WEB CONSOLE"}],"ARM Case Number":"TS009662914","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.2.1;6.3.0;and future releases"}]

Document Information

Modified date:
20 December 2023

UID

ibm17100868