Troubleshooting
Problem
Plain text responses from the Netcool/Impact REST API is returning responses with the wrong content type header.
Instead of returning the "plain/text" content type, the header value is set to "application/atom+xml".
For further information about the REST API, refer to the Accessing policies remotely using the REST API topic.
Symptom
The following request will execute a Netcool/Impact policy:
curl -k -u impactadmin:password https://impacthost:9081/restui/policyui/policy/TestPolicy1/run -v
The endpoint replies with a plain text response but the Content-Type header is incorrectly set to "application/atom+xml":
< HTTP/1.1 200 OK
< X-Content-Type-Options: nosniff
< Content-Type: application/atom+xml
< Content-Language: en-US
< Content-Length: 37
Cause
The REST endpoint is using the default content type instead of an explicitly declared content type.
Diagnosing The Problem
The following endpoints will return an incorrect content type header:
- https://<HOSTNAME>:<PORT>/restui/policyui/policy/<POLICY>/run
- http://<HOSTNAME>:<PORT>/restui/versioncontrol/uncheckout/<POLICY>/policy
- http://<HOSTNAME>:<PORT>/restui/versioncontrol/checkout/<POLICY>/policy
Resolving The Problem
The content-type can be safely ignored. If the request succeeded, the response will include a HTTP 200 status code.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSSHYH","label":"Tivoli Netcool\/Impact"},"ARM Category":[{"code":"a8m500000008ZtnAAE","label":"Impact-\u003EImpact Server"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.1.0"}]
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Document Information
Modified date:
30 November 2023
UID
ibm17085989