Troubleshooting
Problem
Administrator launches 'Cognos Configuration'. The user presses 'start' button. An error appears.
Symptom
8:21:37, 'ContentManagerService', 'StartService', 'Failure'.
08:21:37, CM-CFG-5063 A Content Manager configuration error was detected while connecting to the content store. CM-CFG-5027 Unable to upgrade the content store to the version 7.0026 that is compatible with this version of Content Manager. The current version of the content store is 7.0027.
08:21:38, 'ContentManager', 'getActiveContentManager', 'Failure'.
DPR-CMI-4006 Unable to determine the active Content Manager. Will retry periodically.
08:21:38, 'com.cognos.pogo.contentmanager.coordinator.ActiveCMControl', 'pogo', 'Failure'.
DPR-DPR-1035 Dispatcher detected an error.
null
Cause
The version of the content store database is later than the version of the Cognos software (installed on the application server).
Example:
In one real-life case:
- The content store database was based on Cognos 11.1.7 FP10
- The version of Cognos configuration was Cognos 11.1.6
Resolving The Problem
Either:
(1) Upgrade the version of Cognos analytics install (installed on the application server) to the same (or later) version as the database uses
(2) Restore the content store database (from a backup) from when it had the same version as the content server installed.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
27 November 2023
UID
ibm17071331