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How to fix ActiveMQ transport issue?

Question & Answer


Question

The HPC use ActiveMQ 5.4.2, sometimes it generates the below error message in ActiveMq logs as below and then activemq stop: ================================== 2017-08-11 18:36:50,612 | INFO | Connector openwire Started | org.apache.activemq.broker.TransportConnector | main 2017-08-11 18:36:50,615 | INFO | ActiveMQ JMS Message Broker (localhost, ID:head2-38708-1502465810234-0:1) started | org.apache.activemq.broker.BrokerService | main 2017-08-11 18:36:50,700 | INFO | jetty-7.1.6.v20100715 | org.eclipse.jetty.util.log | main 2017-08-11 18:36:50,769 | INFO | Started SelectChannelConnector@0.0.0.0:8161 | org.eclipse.jetty.util.log | main 2017-08-12 18:32:22,907 | INFO | Transport failed: java.io.EOFException | org.apache.activemq.broker.TransportConnection.Transport | ActiveMQ Transport: tcp:///127.0.0.1:46581 ==================================

Cause

The memory limit is too low

Answer


1. Change the activemq configuration file /opt/pcm/activemq/conf/activemq.xml as below:
<1>. Add schedulerSupport="false" for broker definition.
<broker xmlns="http://activemq.apache.org/schema/core" brokerName="localhost" dataDirectory="${activemq.base}/data" destroyApplicationContextOnStop="true" schedulerSupport="false">

<2>. Disable the "producerFlowControl" as below:

<policyEntry topic=">" producerFlowControl="false" memoryLimit="1mb">

<policyEntry queue=">" producerFlowControl="false" memoryLimit="1mb">

2. Restart the activemq services.

[{"Product":{"code":"SSZUCA","label":"IBM Spectrum Cluster Foundation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"3rd party integrations","Platform":[{"code":"PF016","label":"Linux"}],"Version":"4.2","Edition":"Standard","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Product Synonym

hpc420

Document Information

Modified date:
23 June 2018

UID

isg3T1025651