Troubleshooting
Problem
The Cassandra Database might hang after the IBM Security Guardium S-TAP process goes down.
Symptom
Cassandra Database is hung and the IBM Security Guardium S-TAP process is down.
Cause
Cassandra’s logback framework appears to have the following design flaw:
logback will continue to write audits to the pipe until the pipe is full. When a pipe is full, a blocking writer waits until enough data was read from the pipe to perform the write. When there are no readers for the audit pipe, logback waits indefinitely, which causes the Database to hang. This issue affects any user of the logback framework (not just the IBM Security Guardium S-TAP).
Resolving The Problem
SHORT TERM solution:
Write a script that would check periodically check whether the IBM Security Guardium S-TAP process (STAP) is running. If it’s not running, it would tail the audit pipe (to prevent the Database from hanging), and notify the appropriate personnel that the STAP is down (For example: contact the System Admin asking them to address the STAP down issue).
A sample script (monitor_stap_pipe-1.sh) is attached to this article which may serve as a template for your script.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"ARM Category":[{"code":"a8m0z000000Gp0IAAS","label":"STAP"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
11 October 2023
UID
ibm17051082