Troubleshooting
Problem
特定の環境において、Windows クライアントからのデータベース接続に数秒から数分要することがあります。
Cause
Windows クライアントでデータベース・カタログに AUTHENTICATION オプションを指定していない場合、ローカル・ユーザーの確認が行われます。この処理で呼び出される sqloFindTheUser -> LookUpAccountName API の返りに時間を要することがあります。特に Active Directory を構成している場合、この事象にあてはまりやすくなります。
Environment
Windows クライアントのみ
Diagnosing The Problem
Windows クライアントで、データベース接続時に db2trc -t を採取すると sqloFindTheUser で時間を要していることが確認できます。
Resolving The Problem
不要な LookupAccountName 呼び出しを行わないよう、データベース・カタログで AUTHENTICATION オプションを明示的に指定します。たとえばリモート・ノード DB2SRV にある SAMPLE データベースをカタログしている場合は以下のようなコマンドでカタログを変更します。
- Windows の管理者として Windows クライアントにログオンします。
- 「DB2 コマンド ウィンドウ - 管理者」をひらき、以下のコマンドを実行します。
db2 uncatalog db sample db2 catalog db sample authentication SERVER
運用上の考慮点
- データベース・カタログの変更を反映するにはアプリケーション・プロセスの再起動が必要になる場合があります。市詳細は以下の Technote を参照してください。
[Db2] データベース・カタログの変更を反映する方法
関連情報
CATALOG DATABASE コマンド
UNCATALOG DATABASE コマンド
[Db2] パスポート・アドバンテージによく寄せられる質問
お問合せ先
技術的な内容に関して、パスポート・アドバンテージの契約のもと Db2 テクニカル・サポートへお問い合わせください。
Db2 テクニカル・サポート
CATALOG DATABASE コマンド
UNCATALOG DATABASE コマンド
[Db2] パスポート・アドバンテージによく寄せられる質問
お問合せ先
技術的な内容に関して、パスポート・アドバンテージの契約のもと Db2 テクニカル・サポートへお問い合わせください。
Db2 テクニカル・サポート
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"ARM Category":[{"code":"a8m500000008PkdAAE","label":"Connectivity"},{"code":"a8m500000008PkqAAE","label":"Performance"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
07 October 2023
UID
ibm17048473