IBM Support

Installing a Case solution using REST APIs failed with "CWTBG0737E: An error has occurred on the server. Please ask your system administrator to check the system log for details." error

Troubleshooting


Problem

The customer installed a Case solution by using REST APIs documented at https://www.ibm.com/docs/en/baw/22.x?topic=solutions-installing-case-solution-by-using-rest-apis. The solution deployment failed with "CWTBG0737E: An error has occurred on the server. Please ask your system administrator to check the system log for details." error.

Symptom

The REST API failed with the error as follows:
{
  "state": "failure",
  "last_modified": "2023-09-19T17:19:14.360Z",
  "result": {
    "error": "CWTBG0737E: An error has occurred on the server. Please ask your system administrator to check the system log for details."
  }
}
Enabled trace string below using technote https://www.ibm.com/support/pages/node/6484579#BASFastLiberty
*=info:com.lombardisoftware.expimp.=all:com.lombardisoftware.core.=all:com.filenet.api.exception.=all:com.ibm.bpm.=all:com.ibm.casemgmt.=all:com.filenet.api.=all:com.ibm.bpm.embeddedecm.=all*

 
Here is the excerpt from BAW trace log:
...
[2023-09-19T17:19:13.861+0000] 00001b21 id=00000000 com.ibm.casemgmt.intgimpl.messages.CaseMgmtLogger            < appendMessages() RETURN import REST call failed :Workflow Project Import failed during REST call to url: https://<BAW service endpoint>:9443/CaseManager/CASEREST/v1/solution/import Response Message :<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"><html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The application or context root for this request has not been found: /CaseManager/CASEREST/v1/solution/import</p></body></html>
 
[2023-09-19T17:19:13.861+0000] 00001b21 id=00000000 com.ibm.casemgmt.intgimpl.messages.CaseMgmtLogger            > filter() ENTRY import REST call failed :Workflow Project Import failed during REST call to url: https://<BAW service endpoint>:9443/CaseManager/CASEREST/v1/solution/import Response Message :<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"><html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The application or context root for this request has not been found: /CaseManager/CASEREST/v1/solution/import</p></body></html>
 
[2023-09-19T17:19:13.861+0000] 00001b21 id=00000000 com.ibm.casemgmt.intgimpl.messages.CaseMgmtLogger            < filter() RETURN import REST call failed :Workflow Project Import failed during REST call to url: https://<BAW service endpoint>:9443/CaseManager/CASEREST/v1/solution/import Response Message :<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"><html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The application or context root for this request has not been found: /CaseManager/CASEREST/v1/solution/import</p></body></html>
 
[2023-09-19T17:19:13.862+0000] 00001b21 id=00000000 com.ibm.casemgmt.intgimpl.messages.CaseMgmtLogger            E error import REST call failed :Workflow Project Import failed during REST call to url: https://<BAW service endpoint>:9443/CaseManager/CASEREST/v1/solution/import Response Message :<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"><html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The application or context root for this request has not been found: /CaseManager/CASEREST/v1/solution/import</p></body></html>
 
[2023-09-19T17:19:13.862+0000] 00001b21 id=00000000 com.ibm.casemgmt.intgimpl.messages.CaseMgmtLogger            > cbeLogger() ENTRY ERROR org.apache.commons.logging.impl.Jdk14Logger@baa6cdde import REST call failed :Workflow Project Import failed during REST call to url: https://<BAW service endpoint>:9443/CaseManager/CASEREST/v1/solution/import Response Message :<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"><html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The application or context root for this request has not been found: /CaseManager/CASEREST/v1/solution/import</p></body></html>
 
[2023-09-19T17:19:13.862+0000] 00001b21 id=00000000 com.ibm.casemgmt.intgimpl.messages.CaseMgmtLogger            < cbeLogger() RETURN null
[2023-09-19T17:19:13.862+0000] 00001b21 id=00000000 com.ibm.casemgmt.intgimpl.messages.CaseMgmtLogger            < error() RETURN null
[2023-09-19T17:19:13.862+0000] 00001b21 id=00000000 com.ibm.casemgmt.api.context.CaseMgmtContext                 > set() ENTRY null
[2023-09-19T17:19:13.862+0000] 00001b21 id=00000000 com.ibm.casemgmt.api.context.CaseMgmtContext                 < set() RETURN com.ibm.casemgmt.api.context.CaseMgmtContext@188933d0
[2023-09-19T17:19:13.908+0000] 00001b21 id=00000000 com.ibm.ws.logging.internal.impl.IncidentImpl                I FFDC1015I: An FFDC Incident has been created: "java.lang.RuntimeException: Workflow Project Import failed : Workflow Project Import failed during REST call to url: https://<BAW service endpoint>:9443/CaseManager/CASEREST/v1/solution/import Response Message :<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"><html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The application or context root for this request has not been found: /CaseManager/CASEREST/v1/solution/import</p></body></html>
 com.ibm.websphere.security.auth.WSSubject 177" at ffdc_23.09.19_17.19.13.0.log
[2023-09-19T17:19:14.058+0000] 00001b21 id=00000000 com.ibm.bpm.embeddedecm.caseintegration.api.impl.CaseApiImpl 1 installProject() An unexpected exception occurred. Message was: null
com.filenet.api.exception.EngineRuntimeException: FNRCE0066E: E_UNEXPECTED_EXCEPTION: An unexpected exception occurred. Message was: null
at com.filenet.apiimpl.util.J2EEUtilWSBase.handleException(J2EEUtilWSBase.java:66)
at com.filenet.apiimpl.util.J2EEUtilWSBase.doAs(J2EEUtilWSBase.java:85)
at com.filenet.api.authentication.SubjectCredentials.doAs(SubjectCredentials.java:82)
at com.filenet.api.util.UserContext.doAs(UserContext.java:159)
at com.ibm.bpm.embeddedecm.caseintegration.api.impl.CaseApiImpl.installProject(CaseApiImpl.java:299)
at com.lombardisoftware.expimp.ExportImportManager.importModel(ExportImportManager.java:664)
at com.lombardisoftware.core.deployment.ImportHelper.importSnapshotContents(ImportHelper.java:1051)
at com.lombardisoftware.core.deployment.ImportHelper.importSnapshotContents(ImportHelper.java:1035)
at com.lombardisoftware.core.deployment.ImportHelper.access$200(ImportHelper.java:132)
at com.lombardisoftware.core.deployment.ImportHelper$1.run(ImportHelper.java:504)
...
at com.ibm.ws.concurrent.internal.ManagedThreadImpl.run(ManagedThreadImpl.java:96)
Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.GeneratedMethodAccessor220.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
at java.lang.reflect.Method.invoke(Method.java:508)
at com.filenet.apiimpl.util.J2EEUtilWSBase.doAs(J2EEUtilWSBase.java:81)
... 78 more
Caused by: java.lang.RuntimeException: java.lang.RuntimeException: Workflow Project Import failed : Workflow Project Import failed during REST call to url: https://<BAW service endpoint>:9443/CaseManager/CASEREST/v1/solution/import Response Message :<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"><html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The application or context root for this request has not been found: /CaseManager/CASEREST/v1/solution/import</p></body></html>
...
...

Cause

When a user registered a target environment by using the bawadmin desktop, they did not complete the context root values for both IBM Business Automation Workflow process server context root and IBM Case Manager context root. In IBM Cloud Pak for Business Automation, by default it comes with a custom context root.  You cannot leave the context root for both IBM Business Automation Workflow process server context root and IBM Case Manager context root empty.  You must enter the same context root value for both IBM Business Automation Workflow process server context root and IBM Case Manager context root.

Diagnosing The Problem

  1. Log on to FileNet Content Engine administrative console for Content Engine (ACCE).
  2. Check whether there are values set for both the BPMContextRoot and BPMCallBackContextRoot in the OneBPM Integration Data in the target object store. See sample screen captures here:
  3. image-20231002155651-1
  4. image-20231002155940-2

Resolving The Problem

  1. Log on to bawadmin desktop.
  2. Reregister the target environment.
  3. Make sure to enter the same context root value for both IBM Business Automation Workflow process server context root and IBM Case Manager context root. Note that you can find the context root values by running oc describe pod <Case init pod> or oc describe job <Case init job>.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBYVB","label":"IBM Cloud Pak for Business Automation"},"ARM Category":[{"code":"a8m3p000000hAh9AAE","label":"Operate-\u003EBAW Install\\Upgrade\\Setup-\u003EBAW Case Manager"},{"code":"a8m3p000000LPr8AAG","label":"Use-\u003EBAW App Usage-\u003ECase Manager"}],"ARM Case Number":"TS014180664","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
04 October 2023

UID

ibm17044100