IBM Support

Error "Failed to download master schema" appears during download in Maximo Mobile

Troubleshooting


Problem

Error "Failed to download master schema" appears during configuration download in IBM Maximo Mobile.

Symptom

The error appears in the configuration section of the download.
Configuration error:  Failed to download master schema

Cause

The request for the schema takes longer than 60000 ms (1 minute) to return. The fetchTimeoutValue for the schema request is hardcoded to 60000.

Diagnosing The Problem

The Maximo mobile log displays the time the request for /oslc/graphite/mobile/schema.  Any request longer than 60000 results in error.
 
2023-09-21 16:55:10.477 -04:00 [ERR] {"SourceContext":"IBM.Maximo.Mobile.JSBridge"} : [Webview Console]: 2023-09-21T20:55:10.476Z: [ERROR]: [navigator]: [JS-DisconnectedRESTConnection]: Request for /oslc/graphite/mobile/schema taking 60007 miliseconds 
2023-09-21 16:55:13.722 -04:00 [ERR] {"SourceContext":"IBM.Maximo.Mobile.JSBridge"} : [Webview Console]: 2023-09-21T20:55:13.721Z: [ERROR]: [navigator]: [JS-DisconnectedSchemaFactory]: Error downloading Master Schema{}

Another way to determine how long the schema takes to return is to request the schema manually.
Update the maximoserver in the URL to reflect the Maximo server in your environment. 
http://maximoserver/maximo/oslc/graphite/mobile/schema
Enter the URL in a browser and time how long it takes to return.
 

Resolving The Problem

Performance issues are complex and there can be many contributing factors or solutions. 
One known cause is setting the Maximo Root Logger to DEBUG.  This logger is resource intensive and negatively impacts the amount of time the schema takes to return.  Use debug when actively troubleshooting a problem.  Do not leave debug enabled long term.  Changing the logger from DEBUG back to INFO resolves the schema download error.  

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m50000000CbPpAAK","label":"Mobility-\u003EPlatform"}],"ARM Case Number":"TS014219754","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
19 October 2023

UID

ibm17043474