IBM Support

QRadar SOAR: Backup failure because there are no free Physical Extents on volume group

Troubleshooting


Problem

Running soarSystemBackup fails if there are no Physical Extents allocated to the volume group.

Symptom

The soarSystemBackup command fails with this error.
TASK [prerequisite : Assert enough volume group free space] *********************************************************************************************************************************************************************************
task path: /usr/share/soar-backup/ansible/roles/prerequisite/tasks/main.yml:54
fatal: [localhost]: FAILED! => {"changed": false, "msg": "There is insufficient free space on the volume group resilient to do a backup. Aborting. Please extend the free space of volume group and try again."}

Cause

This client's volume group did not have a free allocation of Physical Extents. Free PE / Size shows zero Physical Extents.
  --- Volume group ---
  VG Name               resilient
  System ID
  Format                lvm2
  Metadata Areas        3
  Metadata Sequence No  12
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                5
  Open LV               5
  Max PV                0
  Cur PV                3
  Act PV                3
  VG Size               <499.60 GiB
  PE Size               4.00 MiB
  Total PE              127897
  Alloc PE / Size       127897 / <499.60 GiB
  Free  PE / Size       0 / 0
  VG UUID               *****************

Diagnosing The Problem

Running sudo vgdisplay on the client's server identified that there was no free space allocated to the volume group.
The virtual appliance has a 4GB free allocation of Physical Extents, which the soarSystemBackup utility uses to dynamically create a logical volume to perform live file transfers as part of the backup process.
With no free Physical Extents, the utility could not run.
The client extended their disk file systems some time before. Presumably, during this process they used all the Physical Extents as opposed to leaving 4GB free.

Resolving The Problem

In this instance, the client used the utility resSystemBackup, which does not use the volume group.
An alternative approach might involve extending or adding new disks and by using operating system commands to extend the volume group into the new disk space created.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSIP9Q","label":"IBM Security SOAR"},"ARM Category":[{"code":"a8m0z0000001h0WAAQ","label":"Installation \/ Upgrade-\u003EOperating System"}],"ARM Case Number":"TS014200594","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
25 September 2023

UID

ibm17038762