Troubleshooting
Problem
A DOORS client silent installation fails.
Symptom
The installation log file (for example at C:\Windows\Temp\DoorsClientInstall.log) shows a message that fully or in part resembles this error:
MSI (s) (xx:xx) [xx:xx:xx:xxx]: Note: 1: 2203 2: C:\WINDOWS\system32\config\systemprofile\AppData\Local\Downloaded Installations\{GUID}\IBM Engineering Requirements Management DOORS 9.7.2.7.msi 3: -2147287037
MSI (s) (xx:xx) [xx:xx:xx:xxx]: MainEngineThread is returning 3
Cause
Windows states:
C:\Users\User>net helpmsg 3
The system cannot find the path specified.
The issue occurs during unpacking of installer files, and failing to write to a temporary path when run from a system account context. This configuration is typically the case with system configuration management tools to distribute DOORS client to client machines.
Resolving The Problem
The recommendation is to run the silent installation command as a local administrator user in a CMD command console.
Other workarounds, such as manually unpacking the installer files, also prove useful, as they too bypass the file system access restrictions the operating system imposes on the system account.
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"ARM Category":[{"code":"a8m3p000000PBzzAAG","label":"ERM DOORS-\u003EInstallation-\u003ESlient install"}],"ARM Case Number":"TS013961508","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.7.2;and future releases"}]
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Document Information
Modified date:
15 September 2023
UID
ibm17032967