IBM Support

How to install ClearCase on Windows without system reboot

Question & Answer


Question

Can I install, update, or uninstall ClearCase on Windows without being required to reboot the system?

Cause

ClearCase is installed by the IBM Installation Manager.  When installing features which require dynamic or automatic view support on Microsoft Windows, the user is prompted to reboot the system as the final step of a successful installation. As of versions 9.0.2.8. 9.1.0.5, and 10.0.1, ClearCase has been enhanced to provide the possibility of completing an install, update, or uninstall without rebooting if certain conditions are met.

Answer

Starting with ClearCase versions 9.0.2.8, 9.1.0.5. and 10.0.1, when installing ClearCase on a Windows system for the first time, or reinstalling after a successful uninstall, rebooting will no longer be required.   For all other scenarios which modify an existing installation, the need for a system restart will depend on whether all open references to MVFS filesystem resources have been fully released. 
This enhancement does not require a ClearCase administrator to make any changes in the way that response files are written for Installation Manager silent install, or navigation and feature selection during an interactive install.  To avoid having to reboot the system, the administrator will most likely need to take action to ensure that open references in MVFS are closed.
Close open file references
Prior to starting any Installation Manager operation to update, rollback, uninstall, or modify ClearCase, the administrator should take action to save work in progress and exit any applications which use resources accessed through a dynamic or automatic view.  This includes:
  • command prompt windows in the M: or R: drives or other drive letters mapped to a view
  • the Windows explorer, which has context menu integration for those drives
  • editors and IDEs, including ClearTeam Explorer (CTE)  and Visual Studo
  • administrative applications such as the ClearCase project explorer or the ClearCase Control Panel 
The ClearCase Control Panel applet has been enhanced to help identify processes with open file handles in the MVFS filesystem.  On the Services Startup tab, when the Stop ClearCase button is clicked, a pop-up listing such processes will open.  After taking action to terminate those processes and refreshing the list, closing the popup will allow the ClearCase stop action to proceed, and in most cases the MVFS service will be stopped. 
Note that use of the Control Panel to stop ClearCase services is not a prerequisite for modifying the ClearCase installation.  Other means of quiescing MVFS activity may still be used.  Also note that there may be situations in which IM still requests the system to be restarted, despite the administrator's effort to stop all activity.  Unseen references may still exist.
Summary of common install operations and changes introduced with this enhancement
Install
Starting with these ClearCase versions, when installing ClearCase or the CCRC offering on a Windows system for the first time, or reinstalling after a successful uninstall, rebooting will no longer be required.  This capability is not supported on Windows 7 systems installing 9.0.2.8.
Uninstall
It is now possible to avoid rebooting when uninstalling by taking actions to close any active references, as described above.
Update
Several factors affect the update scenarios for these ClearCase versions.  The action plan and expected outcome with respect to rebooting will depend on the versions involved.
Updating to 9.0.2.8 will still require a reboot, because the older version does not include the enhanced logic.
Moving from any 32-bit version of ClearCase to a 64-bit versions 9.1.0.x or 10.0.x cannot be handled as an update. This migration to 64-bit requires an uninstall followed by a fresh install.   The user should expect to reboot after the uninstall phase, and but as of 9.1.0.5 or 10.0.1 will not need to reboot again after the install phase.
Moving from any of the previous 64-bit versions (9.1-9.1.0.4 or 10.0.0) to 9.1.0.5 or 10.0.1 will also require an uninstall/reinstall.  This is necessary due to the upgrade of Eclipse within ClearCase and incompatible install mechanics between the old and new Eclipse versions.  The user should expect to reboot after the uninstall phase, and but will not need to reboot again after the install phase.
These documents describe in detail the steps an administrator should follow to update the system to 9.1.0.5 or 10.0.1. 
https://www.ibm.com/support/pages/node/7015361
https://www.ibm.com/support/pages/node/7015375
Once these boundaries have been crossed, future version updates will once again be supported as a single step update operation in Installation Manager.   In that scenario, it may be possible to avoid having to reboot if the administrator was able to successfully close all open file references prior to starting the update.
Rollback
Considerations for rollback are essentially the same as for update. 
9.0.2.8 can be rolled back to an earlier version, however a reboot will be required.
Reverting from 9.1.0.5 or 10.0.1 to the previously installed version will require an uninstall and reinstall, and reboot will be required.
Rollback of future releases will support the possibility of not requiring a reboot, if rolling back to 9.0.2.8, 9.1.0.5, or 10.0.1.
Modify
It is possible to modify an existing ClearCase installation in Installation Manager, to add or remove features.  Features which require the MVFS filesystem are dynamic views, automatic views, local views and VOBs, CCCRC WAN server, and automatic view WAN server.  When any of these features are added to a running 9.0.2.8. 9.1.0.5, or 10.0.1 system, no reboot will be required.  As with the other scenarios, removal of those features may or may not require reboot.
Known issues
Mapped drives for dynamic or automatic are not reconnected after a stop and restart of MVFS Service via Control Panel
If the MVFS is stopped using the enhanced Control Panel, the MVFS driver is unloaded and view context is not accessible. The services start action reloads the MVFS and starts the albd_server, but does not restart any view_server processes.
 
Workaround:  use cleartool startview to restart the views

Actions that fail after install/update due to process EVs not being refreshed
The path to executables in the ClearCase installation is read from the system environment variables.  After an install/update with no system restart, the user may experience actions failing with an error that the executable was not found. 

Workaround: In many cases, opening a new command prompt and retrying the operation is sufficient. The installer will have tried to restart the desktop explorer, so any new processes will inherit the updated environment. However, in some cases if the desktop explorer was not restarted, the user needs to trigger the updated EVs to be read.  There are several ways to do this, the simplest way is to log out and log back in.

Antivirus applications may block the ClearCase Control Panel
The enhanced Control Panel must be run with administrator access, and antivirus systems may block execution from the command line.
Workaround:  The ClearCase Control Panel can be launched from the Windows Control Panel, or use net stop commands to stop services.

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Document Information

Modified date:
03 October 2023

UID

ibm17028842