IBM Support

TM1 Application - Could not connect to the TM1 Server

Troubleshooting


Problem

When users try to load TM1 Application with TM1 Application portal under http://<Webserver>:9511/pmpsvc , receives error message as following:
"Could not connect to the TM1 Server"
image-20230811123838-1
This same error can be noticed when try log in to Performance Modeler.

Cause

Issue can be related to missing configuration cube. Cube "}ElementAttributes_}tp_system_config" is missing.

Diagnosing The Problem

In pmpsvc.log following error message appears:
ERROR (listApplications) com.ibm.cognos.pmpsvc.session.PMPSVCSession - An exception occurred while initializing TM1 session
com.ibm.cognos.pmpsvc.PMPSVCException: Invalid application definition format. :APPDEF_FORMAT

Resolving The Problem

Copy "}ElementAttributes_}tp_system_config" cube from data folder of TM1 Database sample or working environment and paste to data folder of affected TM1 Database.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m3p000000PC7XAAW","label":"Planning Analytics-\u003EWeb PASS Contributor Application"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
11 August 2023

UID

ibm17025423