Troubleshooting
Problem
The /maximo/api/members/thisserver/pingdb MMI call returns a database connection error when Microsoft SQL Server database is used with IBM Maximo Manage application in IBM Maximo Application Suite. The error message displayed is as follows:
05 Jul 2023 07:54:34:518 [ERROR] [MXServer] [CID-MXOSLC-233823] ping db connection error -- The statement did not return a result set.
Symptom
The /pingDB MMI call shows empty braces with no data, that is, '{}'.
On checking Maximo Manage logs, the following stack trace can be seen:
05 Jul 2023 07:54:34:518 [INFO] [MXServer] [CID-MXOSLC-233823] Correlation started, correlation data added: ResponseResourceSize:2
On checking Maximo Manage logs, the following stack trace can be seen:
05 Jul 2023 07:54:34:518 [INFO] [MXServer] [CID-MXOSLC-233823] Correlation started, correlation data added: ResponseResourceSize:2
05 Jul 2023 07:54:34:518 [INFO] [MXServer] [CID-MXOSLC-233823] Correlation started, correlation data added: ResponseResourceSize:2 SendResponseTime:0
05 Jul 2023 07:54:34:519 [INFO] [MXServer] [CID-MXOSLC-233823] Correlation started, correlation data added: ResponseResourceSize:2 RequestURI:/maximo/api/members/thisserver/pingdb SendResponseTime:0
05 Jul 2023 07:54:34:519 [INFO] [MXServer] [CID-MXOSLC-233823] Correlation started, correlation data added: ResponseResourceSize:2 RequestURI:/maximo/api/members/thisserver/pingdb SendResponseTime:0 RequestParams:lean=1&ccm=1
05 Jul 2023 07:54:34:519 [INFO] [MXServer] [CID-MXOSLC-233823] Correlation started, correlation data added: ResponseResourceSize:2 RequestURI:/maximo/api/members/thisserver/pingdb SendResponseTime:0 ClientIP:10.128.3.164 RequestParams:lean=1&ccm=1
Cause
When SQL Server database is used, an empty query string is executed, resulting in an empty result set.
Environment
Maximo Manage version 8.6
Maximo Application Suite version 8.10
SQL Server database
Maximo Application Suite version 8.10
SQL Server database
Resolving The Problem
Ignore the error log statement seen in logs, when /pingDB MMI call is executed on SQL Server Database.
Run the following query manually to confirm database connectivity and the total time taken to execute the last 10 queries.
- Use the following query statement to find the total time taken to execute the last 10 queries:
select top 10 avg(total_elapsed_time) from sys.dm_exec_query_stats - Grant access on the view:
grant view server state to maximo
Note: It is planned to include a resolution for addressing the database connection error with the next patch release for Maximo Manage.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAeaAAE","label":"Maximo Application Suite-\u003EMAS Applications-\u003EManage"}],"ARM Case Number":"TS013531279","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
11 August 2023
UID
ibm17025113