IBM Support

In a multi-location store, transfer orders are getting received only under DOCK-LOCATION

Troubleshooting


Problem

In a multi-location store, users are manually receiving inventory. It is getting received only at DOCK-LOCATION and then a putaway task is being created. User must perform putaway to manually move inventory from DOCK-LOCATION to DEFAULT-LOCATION.

Symptom

In a multi-location store, manual receiving of inventory is happening only at DOCK-LOCATION.

Cause

This is happening due to absence of putaway preference for a specific store or at tenant level.

Environment

 IBM Sterling Store Engagement (Next-generation) SaaS

Resolving The Problem

Putaway preference can be created for a specific store or at tenant level, by passing the flag "putawayRequired": false. Post creating this preference, receive the inventory for transfer order. Putaway tasks won't get created.

Sample input for creating the putaway preference:

{   

    "inventoryStatuses": [

        {

            "fromInventoryStatus": "RECHOLD",

            "toInventoryStatus": "GOOD"

        }

    ],

    "includeLocations": null,

    "putawayRequired": false,

    "excludeLocations": [

        {

            "locationId": null,

            "zone": null,

            "type": "abc"

        }

    ],

    "startDate": null,

    "endDate": null,

    "stores": null

}

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cxzVAAQ","label":"Call Center Store and SIM"}],"ARM Case Number":"TS013305026","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
29 August 2023

UID

ibm17022440