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"No items to display" error encountered when searching for items in IBM Sterling Call Center

Troubleshooting


Problem

When searching for certain items on the Call Center UI, "No items to display" message is returned.
Error is seen despite of incremental build being active and the latest catalog being active

Symptom

Upon reviewing logs, we see the Error: Could not find active search index.
No particular pattern was seen for the problematic items. The error occurred for random items.

When the searchCatalogIndex API input was run from the API tester, the item list is returned empty when run from API tester for nonworking items.

Error:

<Attribute Name="ErrorCode" Value="YCM85_016"/>

<Attribute Name="ErrorDescription" Value="Could not find active search index."/>

Catalog Index Build does not work for certain specific items and it throws an error.

Cause

One of the reasons for this is due to MaxModifyTs not updated in YFS_ITEM table. When the incremental build is run, it checks if MaxModifyTs value for the item is more than the last successful index build. For an item to be eligible to be picked during the catalog build, the MaxModifyTS value in YFS_ITEM should be updated to the latest/current date.
 

Diagnosing The Problem

Check MaxModifyTs time in YFS_ITEM for affected items to see if the value is older than the date of the last successful index build.

Resolving The Problem

Keep the MaxModifyTs time in YFS_ITEM updated to latest/current date for that item to be eligible to be picked during the catalog build.
Please refer the documentation:

https://www.ibm.com/docs/en/order-management?topic=transactions-create-catalog-index

The parameter Incremental Build needs to be set to Y to rebuild the existing index file. If you specify Y, Sterling Order Management rebuilds the index based on the last successful index build. The MaxModifyTS column in the YFS_ITEM table determines whether or not an item's attributes have changed. If any external attributes of an item have changed, update the MaxModifyTS column by calling the manageItem API on the item.

As the customer has incremental build on, the MaxModifyTs time in YFS_ITEM should be updated to the latest date for that item to be eligible to be picked during the catalog build.

The value for MaxModifyTS is updated to the latest time when an item is modified.

Document Location

Worldwide

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Document Information

Modified date:
27 December 2023

UID

ibm17012039