IBM Support

Login Issue in IBM Sterling Store Engagement | "Menu Key not found"

Troubleshooting


Problem

The ISF application is installed successfully but login is failing with error mentioned:
<Attribute Name="ErrorCode" Value="YCP0304"/>
<Attribute Name="ErrorDescription" Value="Menu Key not found."/>
<Attribute Name="AdditionalInfo" Value="ApplicationName=ISFSYS00001: MenuId=SOP_PCA_CONSOLE_MENU"/>

Symptom

1. ISF Application not found inside menu group in the configurator.
2. Application was not enabled inside resource in the configurator.
Application_not_enabled

Cause

Issue was caused due to factorysetup not loaded for the store application during the installation.

Diagnosing The Problem

We checked and found out that ISF ( IBM Sterling Store Engagement ) application ISFSYS00001 is missing from menu group and resources as well.

Resolving The Problem

1) Run the command to load factory setup for store application.

./loadDefaults.sh /websphere/IBM/V10.0/Foundation/repository/factorysetup/isf/isf_installer.xml /websphere/IBM/V10.0/Foundation/repository/factorysetup/isf/XMLS

2) Restart the application server.

Related Information

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cxzVAAQ","label":"Call Center Store and SIM"}],"ARM Case Number":"TS013019808","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
07 July 2023

UID

ibm17010287