IBM Support

After submitting a report the View Schedule screen has Invalid Bindings

Troubleshooting


Problem

After successfully scheduling a report the View Schedule screen shows invalid bindings.

Symptom

image-20230629165415-1

Cause

There might be scheduled reports in the system for reports that do not exist.

Diagnosing The Problem

The following sql will identify if this is an issue
SELECT * FROM reportsched WHERE reportname NOT in(SELECTDISTINCT reportname FROM reportdesign)

Resolving The Problem

If the sql statement returned any rows the issue is caused by the orphaned entries in the REPORTSCHED object.
This should never happen through normal Maximo usage as a report cannot be deleted through the UI if there are any schedules for it.  However, during a migration or upgrade perhaps some reports were removed and the schedule remains.
These records in REPORTSCHED need to be removed manually.

Document Location

Worldwide

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Document Information

Modified date:
29 June 2023

UID

ibm17008637