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How to troubleshoot database connection issue with Cognos Analytics

Troubleshooting


Problem

XQE-DS-0006 Unable to logon to the data source. Communications link failure

Cause

Diagnosing The Problem

A.Review Error message from log file
0.Navigate to C:\Program Files\ibm\cognos\analytics\logs\XQE
1.Open xqelog-yymmdd-timestamp.xml and review error code
<event component="XQE" group="Exception" level="ERROR" thread="51" timestamp="2023-05-01 19:47:07.280" contextId="4" requestId="2lyjyv8MGwCqjyj98l8dMCqGwh9C2y2jwd8Ms99d" sessionId="56444ed8:187da54d4cb:-7fd0">
<![CDATA[Caught error in V5QueryHandler: XQE-DS-0006 Unable to logon to the data source
2.Check the detail error message Caused by section
Caused by: java.sql.SQLException: Invalid parameter: useOAuth2
Caused by: The last packet sent successfully to the server was 0 milliseconds ago.
Caused by:PKIX path building failed: com.ibm.security.cert.IBMCertPathBuilderException: unable to find valid certification path to requested targetPKIX path building failed:
Caused by:The TCP/IP connection to the host, port 1433 has failed. Error: "connect timed out
These are not CA error message, please check with DBA to find out why the JDBC Connection string fail from Cognos Analytics Server

Resolving The Problem

You can test jdbc conneciton string with DB client tool such as "Dbeaver or squirrel-sql client.

https://dbeaver.io/

1

JDBC connection string can test without Cognos Analytics

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6nAAC","label":"Data Source"}],"ARM Case Number":"TS010746507","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
30 June 2023

UID

ibm17008621