IBM Support

The Cognos Analytics server can't communicate with the Jupyter server

Troubleshooting


Problem

The Cognos Analytics server can't communicate with the Jupyter server

Symptom

431 Request Header Fields Too Large error attempting to logon to Notebook

Cause

too low for cookies header size 

Diagnosing The Problem

Resolving The Problem

0.Open IIS

1. Click the bi folder under the ibmcognos application.

2. Double-click Request Filtering.

3. Click the Headers tab

1

4. Select the current Cookie header and select Remove

5. Select Add Header to add new Cookie header with a higher Size Limit. (4096 to 8192)

6. Recycle IIS

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m0z000000GpAVAA0","label":"Jupyter Notebook"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
29 June 2023

UID

ibm17008465