Troubleshooting
Problem
Cognos Analytics is unable to test with DB2 data source connection via ODBC or CLI driver (32bit)
Symptom
QE-DEF-0285 The logon failed. QE-DEF-0325 The logon failed for the following reason:
UDA-SQL-0107 A general exception has occurred during the operation "attach".
[IBM][CLI Driver] SQL1031N The database directory cannot be found on the indicated file system. SQLSTATE=58031
Cause
ODBC and CLI are using local system environment variable, this need to set up in OS level before testing the data source connection via Cognos Analytics
Environment
Cognos Analytics 11.2.4
Diagnosing The Problem
Resolving The Problem
1.Open ODBC Data Source Administrator (32bit)
2.Click for Add, and Select IBM DB2 ODBC DRIVER
3.Type TCP/IP for Database name, alias, Host name, port number
4.Type Data Source User ID and Password
5.Test the connection DB2
6. Set up Data source connection via Cognos Administration
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6nAAC","label":"Data Source"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
27 June 2023
UID
ibm17007483