IBM Support

Abrupt "The application failed to respond" and session logout while working in IBM Sterling Call Center in Chrome

Troubleshooting


Problem

Chrome users may notice an abrupt, generic error message when working in IBM Sterling Call Center which states: "The application failed to respond".  This may occur on any of the Call Center screens, especially while working or navigating through Orders, searching orders, resolving holds, etc. Along with the error message, the user is logged out and needs to log back in to resume their task.

Cause

The Chrome browser has a default connection KeepAlive timeout of 5 minutes and does not honor a server's KeepAlive response header. What can occur is a race condition wherein the server's KeepAlive timer expires just milliseconds before Chrome's timer does.  Chrome attempts to reuse that connection, but the server abruptly terminates it, which appears as a failed request on the user's browser.  The UI framework then displays a corresponding error.

Diagnosing The Problem

TCP/IP packet traces are required to identify this issue.  In the packet trace, you should see a FIN, ACK from the server in response to the failed request.

Resolving The Problem

To workaround this condition, set your KeepAliveTimeout in your web server's configuration to a value slightly higher than the Chrome timeout of 5 minutes to provide a buffer.

For example, in the case of IBM HTTP Server, or apache, use the following property:

KeepAliveTimeout 300999ms

Be sure to restart your web server after making the change.

While the higher KeepAliveTimeout has the potential to keep more threads in memory, for most customers this should not present a problem. However, an alternative solution to this problem can be to install APAR PH48206 for IBM HTTP Server.  With this APAR, and after setting the KeepAliveTimeoutSend408 directive to ON (defaults to OFF) instead of terminating the connection, the server will return an HTTP 408 code. This response instructs the web browser to automatically retry their request instead of failing.

Document Location

Worldwide

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Product Synonym

IBM CallCenter; IBM Sterling CallCenter; CallCenter; WebCOM

Document Information

Modified date:
23 June 2023

UID

ibm17006417